Hyper-V Core Netzwerkgeschwindigkeit Gastsystem zu langsam

In einigen Hardwarekonstellationen kann es vorkommen das der die VirtualMachineQueue (VMQ) auf dem Hyper-V Host deaktiviert werden sollte.

Zum deaktivieren oder Aktivieren der VMQ Funktion einer Netzwerkkarte geht man in den Geräte Manager und deaktiviert diesen.

 

Bei einer Hyper-V Core Installation ist es standardmäßig jedochnicht so einfach möglich den grafischen Geräte-Manager zu benutzen um auf den Netzwerkkarten das VMQ zu deaktiveren.

Eine alternative Möglichkeit bietet die Powershell:

Powershell auf dem Hostsystem öffnen:

c:\> Powershell

Netzwerkadapter mit VMQ Übersicht anzeigen:

PS C:\> Get-NetAdapterVmq

Hier erscheinen nun alle Netzwerkkarten und der jeweilige VMQ Status.
Den entsprechenden Eintrag wählen und wie folgt Deaktivieren und Aktivieren

e.g.: NIC2

PS C:\> Disable-NetAdapterVmq NIC2

Aktivieren dann:

PS C:\> Enable-NetAdapterVmq NIC2

Thats IT:)

#Exchange 2013 Outlook Anywhere Basic Einstellungen

Die Standardeinstellungen falls man KEIN Autodiscover für Exchange 2013 benutzt könnten so aussehen:

Server aufrufen: https://exchangeserver/ecp

Unter Server – Server – Editieren – Outlook Anywhere: Externen Namen leer lassen für keinen Filter und eintragen wenn nur über eine bestimmte URL der Zugriff möglich sein soll. Bei der Authentifizierung auf “Einfach” oder “Basic” stellen.

Exchange_OA_1

Exchange_OA_2

brainDUMP: Terminalserver Installationsmodus und Ausführungsmodus

Um in den Installationsmodus oder Ausführungsmodus zu wechseln gibt es einige kurze Shell-Befehle:

 

Command öffnen (Start -> cmd)

Installationsmodus

change user /install

Benutzersitzung ist bereit für die Installation von Anwendungen.

 

Ausführungsmodus

change user /execute

Benutzersitzung ist für die Ausführung von Anwendungen bereit.

 

Abfrage welcher Modus gerade aktiv ist

change user /query

AUSFÜHRUNGSMODUS für Anwendungen ist aktiviert.
INSTALLATIONSMODUS für Anwendungen ist aktiviert.

Microsoft #Office #Sway erste Erfahrungen

Vor einigen Wochen habe ich mich für die Preview von Microsoft Sway angemeldet. Vor ein paar Tagen dann ist die ersehnte E-Mail – “It’s here. Your Sway Preview invite is ready.” gekommen.

swayinvite

Kurz vorab: Was ist Sway?

Microsoft Office Sway ist eine Multi-Plattform Präsentationsanwendung. Man kann Inhalt in intuitiven Präsentation veröffentlichen und teilen. Sway ist eine Browseranwendung die auf allen Endgeräten problemlos funktioniert.

 

Mit der Einladung kann man jeweils zwei Microsoft Accounts für die Nutzung von Sway freischalten. – Gesagt getan!

Nachdem ich mich bei Sway eingelogt hat erscheint ein großer Button “Create Sway” auf der darauffolgenden sehr übersichtlich gestalteten Seite hat man die Möglichkeit sogenannte “cards” anzulegen.

Create first Sway

Startseite

 

Der Start ist einfach und selbsterklärend – Nachdem ich den Titel gewählt und eine “Textcard” hinzugefügt habe kann man sich mit den – in der Preview – noch recht dürftig ausgestatteten Layouts beschäftigen.

swaycard

Klickt man auf den Rechten Rand wechselt die Ansicht in den Vorschaumodus – ein Klick Links führt wieder zurück zum Entwurfsmodus zurück.

swaypreview1

 

Um das (oder den?) Sway mit ein wenig Inhalt zu füllen habe ich ein paar Reisefotos eingefügt. Hier gibt es eine Auswahl von Quellen die Sway verwenden kann.

swayinputmedia

 

Nach dem einfügen kann man das Layout noch anpassen und den Content gruppieren. Die Auswahl hierfür ist in der Preview noch sehr stark eingeschränkt.

swayimagelayout

swaylayout

 

Fühlt man sich unkreativ kann man im Vorschaumodus einfach den “Remix!” Button klicken und schon wird das Layout gewechselt. Derzeit müssten so ca. 7-10 Layouts eingefügt sein bis man wieder zur ursprünglichen Ansicht kommt.

swayremix

 

Fazit:

Microsoft hat mit Sway ein wirklich tolles Werkzeug an den Start gebracht um in kurzer Zeit schicke Ergebnisse zu erzielen.
Die vielen “Coming Soon” Buttons in der Preview machen Neugierig auf das Endergebnis.
Was mich noch ein wenig stört ist der fehlende “Zurück” Button wie man Ihn bei Office gewohnt ist. Denn es passiert sehr schnell das man aus versehen eine “Card” löscht. Diese lässt sich dann nicht wiederherstellen.

 

Teilen kann man den fertigen Sway via Facebook, Twitter, Link und iFrame zum einbinden (wie hier)

Exchange 2010 Management Konsole Initialisierungsfehler

Exchange Initialisierungsfehler

Exchange Konsole Initialisierungsfehler

Es kann vorkommen das beim öffnen der Exchange Management Konsole 2010 folgender Fehler erscheint:

Fehler beim Versuch, eine Verbindung mit dem angegebenen Exchange-Server xy herzustellen.

Fehler beim Verbindungsversuch mit xy/PowerShell mithilfe von “Kerberos”-Authentifizierung: Beim Verbinden mit dem Remoteserver ist folgender Fehler aufgetreten: Die Anforderung kann vom WS-Verwaltungsdienst nicht verarbeitet werden. Die für das System zulässige Auslastungsquote wurde überschritten. Senden Sie künftige Anforderungen mit einer geringeren Übertragungsrate, oder erhöhen Sie die Auslastungsquote für das System. Weitere Informationen finden Sie im Hilfethema “about_Remote_Troubleshooting”.

 

1. IIS Neu starten

2. Hilft das noch nicht – Exchange PowerShell starten:

set-item wsman:\localhost\MaxConcurrentOperations -value 4294967295 (oder höher)

und/oder pro User hochsetzen:

set-item wsman:\localhost\MaxConcurrentOperationsPerUser -value 1500

 

DSL Internet Zugangsdaten aus dem Router auslesen

Aus aktuellem Anlass dachte ich mir, dass ich eine kurze Anleitung für das herausholen von Internet Zugangsdaten aus einem Router schreibe. Wechselt man die Kiste alle zwei Jahre sind die Zugangsdatenzettel schon seit mindestens 3 Jahre verschwunden.

Hier beschrieben die Speedports der Telekom und die AVM FritzBoxen.

 

Los gehts:

1. Das “Ich kann keine unverschlüsselten Daten im Klartext lesen” Helfertool – Wireshark (http://www.wireshark.org/download.html) herunterladen.

2.Auf dem Router einloggen (http://fritz.box oder http://speedport.ip oder halt über die IP. Mal verweisen die Seiten auf https://speedport.ip mal nicht – uninteressant)

3. Dieser Punkt ist nur für Telekom Zugangsdaten hilfreich:

In das Zugangsdaten Fenster gehen und im Chrome oder Firefox auf “Element Untersuchen” drücken. Dort so lange suchen bis die input Boxen vom Typ “password” Sichtbar angezeigt werden. Den “password” typen einfach in “text” ändern. Nun werden alle Daten im Klartext angezeigt – außer das Passwort – da steht ein Dummy-Wert.

Bei anderen Anbietern steht der Benutzername sowieso im Klartext da.

4. DSL/ATM Paketmitschnitt aktivieren

Dazu öffnen wir eine neue Registerkarte im Browser und gehen je nach Routertyp auf

http://speedport.ip/html/capture.html

http://fritz.box/html/capture.html

http(s)://speedport.ip/wan_util.stm
usw.

und drücken dort auf Start. Man wird dazu aufgefordert eine Datei abzuspeichern. Dort einen schattigen Ort auswählen und auf Speichern drücken. Der Download endet nicht – also laufen lassen!

5. Auf der Konfigurationsseite des Routers trennen wir die DSL Verbindung und bauen Sie erneut auf. Entweder durch “Speichern” bei den Zugangsdaten drücken oder Trennen/Neu Verbinden usw.

6. Auf der Capture oder wan_util Seite auf “Stop” drücken. Die Datei ist nun fertig heruntergeladen.

7. Die Datei per Drag n Drop in den Wireshark ziehen (oder über öffnen)

8. Im Wireshark mit Strg+F den Typ “String” auswählen und “Authenticate” eingeben. Da steht dann Entweder “Authenticate-Request” oder “Authenticate Request” rechts oder für die fließigen – unten in den Details kann man sich dann durh ausklappen der PPP Password Authentication Protokoll Zeile und der Data Zeile den Benutzernamen und das Passwort im Klartext anzeigen lassen.

 

Wie der Protokollname schon sagt – das geht ausschließlich mit PAP Einwahlen. CHAP sendet die Daten verschlüsselt.

PS: Manche Boxen zicken erst ein wenig rum wenn man in zwei Tabs die Konfiguration und den Capture offen hat wegen doppelten Administrator Zugriff – das lässt sich aber natürlich kinderleicht umgehen.

Mit Mikrotik DDOS Attacken erkennen und filtern

Um DDoS Attacken aus Botnetzen zu erkennen und sich davor ein wenig zu schützen sind nur wenige Eingriffe im RouterOS nötig.

Wir legen erst einmal eine Regel an, die alle eingehenden Pakete zu einer neuen Regel sendet.
Mithilfe der neuen Regel werden unkritische Pakete weitergeleitet – Anschließend können noch Ausnahmen für DNS und NTP Server erstellt werden.
Alle Absender deren Pakete nicht durchgereicht worden sind kommen 10min auf die Sperrliste. Genau das gleiche mit den Angreifenden IPAdressen.

Hört der Angriff auf verschwinden die IP-Adressen wieder aus der Adressliste da wir die oft unwissenden befallenen Rechner nicht auf ewig blocken möchten.

Im Routerboard folgendes einfügen:


/ip firewall filter
add chain=forward connection-state=new action=jump jump-target=detect-ddos
add chain=detect-ddos dst-limit=32,32,src-and-dst-addresses/10s action=return
add chain=detect-ddos src-address=192.168.178.10 action=return
add chain=detect-ddos action=add-dst-to-address-list address-list=ddosed address-list-timeout=10m
add chain=detect-ddos action=add-src-to-address-list address-list=ddoser address-list-timeout=10m
add chain=forward connection-state=new src-address-list=ddoser dst-address-list=ddosed action=drop


 

Eine weitere Möglichkeit die Attacken später nachzuvollziehen bieten Icinga oder Zabbix indem man einfach die Adresslisten einbindet und entsprechende Regeln erstellt.

 

 

opblog templates – die wahl der qual

template ausgewählt: check
plugins deaktiviert: check
schreibschutz aktiviert: check

jetzt kann es losgehen.